Why it is directed to Home Page or 404 page when clicking on Widget in the Backend?  

  RSS

0

When clicking on Themes or Plugins, it will redirect back to the main page of the site or 404 pages. This is the redirect error in WordPress.

How to fix redirect from theme or plug-in sections

Step 1. First, log into your cPanel dashboard.

Step 2. Once logged into the cPanel, find the Files category and then look for the File Manager icon. Enter the File Manager choosing the Home Directory option. Also, be sure that the radio button option for Show hidden files (dotfiles) is selected as well, since the file we are going to edit is one of these types. Click on the Go button.

Step 3. This lists the files in the topmost directory of your account, also known as the Home Directory. From here, look for a file entitled .htaccess. If one is found, you will want to open the file for editing.

Step 4. Now that the file is open for editing, look for a line of code that looks like the following:

AddHandler application/x-httpd-php52 .php

After locating that specific line of code place a hash # at the very front of the line to comment it out so it does not run.

#AddHandler application/x-httpd-php52 .php
If you do not find the .htaccess file at the home directory level or see this line of code in the .htaccess file, look through the other folders such as public_html or other subdirectory folders for WordPress instances to see if there is one there. It is normally in the home directory or public_html folder, however.
 Step 5. Once you have disabled the line of code, then click on the Save Changes button in the upper right corner of the screen to save the change. Now you can attempt to visit the areas of your WordPress site that were previously affected and they should now work properly.
 
---
Actually, this is not the error of WordPress themes or plugins, it's about the configuration of your hosting. 
You can contact your hosting provider to get the best support.
 
Source: inmotionhosting.com
 
This topic was modified 4 weeks ago by Mai Nguyen
 
Share: